Cisco ACL Riflessive

Da Andreabont's Wiki.

Le ACL Riflessive di IOS sono un particolare tipo di ACL che si divide in una parte che logga i pacchetti che passano (di solito in uscita da un'interfaccia) e in una parte che legge i pacchetti loggati e setta delle regole al volo per permettere di ricevere la risposta a quei pacchetti (di solito in entrata)

Esempio

interface FastEthernet0/0
 ip address 192.168.89.254 255.255.255.0
 ip access-group ESTAB-IN in
 ip access-group ESTAB-OUT out
!
ip access-list extended ESTAB-OUT
 permit tcp any any reflect ESTAB-REF-TCP timeout 300
 permit udp any any reflect ESTAB-REF-UDP timeout 60
 permit icmp any any reflect ESTAB-REF-ICMP timeout 60
!
ip access-list extended ESTAB-IN
 evaluate ESTAB-REF-TCP
 evaluate ESTAB-REF-UDP
 evaluate ESTAB-REF-ICMP
 deny ip any any log