Cisco NAT

Da Andreabont's Wiki.

Il NAT in IOS viene gestito "all'interno" del dispositivo: Il pacchetto entrante passa prima dalle ACL, poi viene applicata la regola di NAT, si effettua il routing, si applica l'ACL in uscita e alla fine viene spedito.

Esempio

interface FastEthernet0/0
 ip address 192.168.80.1 255.255.255.0
 ip nat outside
!
interface FastEthernet0/1
 ip address 192.168.90.1 255.255.255.0
 ip nat inside
!
ip access-list extended PUBLIC-NAT
 permit ip 192.168.90.0 0.0.0.255 any
!
ip nat pool PUBLIC-NAT-POOL 192.168.80.10 192.168.80.20 prefix 24
ip nat inside source list PUBLIC-NAT pool PUBLIC-NAT-POOL overload